Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Groups Groups
  • OnYrMrk's Avatar
    2 Minutes Ago
    OnYrMrk replied to a thread Help again in Amplifier Help
    That Kicker amp is only stable to 20hms mono. You are running two 12" Massive subs. As Chris stated, you might want to check the impedance rating of your subs. If you have them wired to give that...
    7 replies | 48 view(s)
  • King Mustard's Avatar
    17 Hours Ago
    I live in the UK and I have a Pumpkin ND0294B. Configuring the software in the car (trying out various pieces of software etc.) is a bit of a ball ache. Is there such a thing as a head...
    0 replies | 16 view(s)
  • ponyXpress's Avatar
    3 Days Ago
    Update: The install shop replaced the power distributions module (I forget what the correct name of this device is, but they installed it when they installed the new head unit). As before, I had no...
    5 replies | 309 view(s)
  • ponyXpress's Avatar
    3 Days Ago
    Update: The install shop replaced the power distributions module (I forget what the correct name of this device is, but they installed it when they installed the new head unit). As before, I had no...
    5 replies | 309 view(s)
  • Chris from Washington's Avatar
    3 Days Ago
    OK, so I would try and find out the model of the subs. Need to know what the impedance of the subs are. I want to make sure you don't have them wired in a way, that would cause issues with...
    7 replies | 48 view(s)
  • Chris from Washington's Avatar
    3 Days Ago
    Chris from Washington replied to a thread Help in Deck Help
    hmm, if the noise is coming through the speakers not attached to the amp. I don't think there will be much you can do, besides trying to get a better ground. But I have a feeling since the deck...
    3 replies | 31 view(s)
  • guidrozb1996's Avatar
    3 Days Ago
    guidrozb1996 replied to a thread Help in Deck Help
    Speakers are going through deck no amp other than the subs Sent from my SM-G892A using Tapatalk
    3 replies | 31 view(s)
  • guidrozb1996's Avatar
    3 Days Ago
    guidrozb1996 replied to a thread Help again in Amplifier Help
    Gain is set to half wayish Sent from my SM-G892A using Tapatalk
    7 replies | 48 view(s)
  • guidrozb1996's Avatar
    3 Days Ago
    guidrozb1996 replied to a thread Help again in Amplifier Help
    Amp is a kicker c1200.1 and I couldnt find the sub model from google I'm at work right now and the subs are in my suv at the office. Wires are ran from the battery to the amp ground is to a bolt...
    7 replies | 48 view(s)
  • guidrozb1996's Avatar
    3 Days Ago
    guidrozb1996 replied to a thread Help again in Amplifier Help
    I'm sorry wrong post. Give me a second to find it Sent from my SM-G892A using Tapatalk
    7 replies | 48 view(s)
  • guidrozb1996's Avatar
    3 Days Ago
    guidrozb1996 replied to a thread Help again in Amplifier Help
    It's not a sub/amp issue it's been there before I got the subs so its deffinately a radio issue Sent from my SM-G892A using Tapatalk
    7 replies | 48 view(s)
  • Chris from Washington's Avatar
    4 Days Ago
    Welcome to the forum. Do you know if your Tundra has a factory amp anywhere in the existing system? If not, what you could do is run the speaker wire from the amp to the harness and tie into it...
    1 replies | 36 view(s)
  • Chris from Washington's Avatar
    4 Days Ago
    Chris from Washington replied to a thread Help in Deck Help
    So it being a dual headunit is not helping matters, but maybe we can try and make it better. Are your speakers going through an amp, or just the deck? ' If all your speakers that are making...
    3 replies | 31 view(s)
  • Chris from Washington's Avatar
    4 Days Ago
    Hi Welcome to the forum. Let's see if we can figure out the issue. Could you let us know the model number of the amp, and also the subs you have? Also how do you have them wired? Where is...
    7 replies | 48 view(s)
  • guidrozb1996's Avatar
    4 Days Ago
    guidrozb1996 started a thread Help again in Amplifier Help
    Would my amp be too small, my wires, or some other problem if everytime I turn my radio to a certain volume it sends my amp into protection mode until I turn it down again. I have a 2400 watt kicker...
    7 replies | 48 view(s)
  • guidrozb1996's Avatar
    4 Days Ago
    guidrozb1996 started a thread Help in Deck Help
    Alright I know this is the basics but I've been trying to figure out why I have feedback coming from my head unit. It's the annoying alternator feedback that gets worse as I accelerate more. I added...
    3 replies | 31 view(s)
  • ghill687's Avatar
    4 Days Ago
    I have a 2017 Tundra and I want to upgrade the system. I have a 5 channel amp that I am going to run. I know how to wire it up with the factory head unit, but I am thinking about upgrading that too....
    1 replies | 36 view(s)
  • Briankanexyz's Avatar
    1 Week Ago
    Briankanexyz replied to a thread Wiring help in Deck Help
    No power antenna. may be a standard harness across the Kia line. Power antenna may refer to power for the fin.
    5 replies | 135 view(s)
  • Chris from Washington's Avatar
    1 Week Ago
    Does your KIA have a power Antenna? The images I'm looking at of the car, it looks like it has a shark fin antenna on the back. So unless you have a antenna that goes up/down (most cars don't have...
    5 replies | 135 view(s)
  • Briankanexyz's Avatar
    1 Week Ago
    Briankanexyz replied to a thread Wiring help in Deck Help
    Thanks for the reply. The Kia hardness i have says 6 volts for the camera so I'd go with that, don't really know the difference. Ill have to check if my deck has the vehicle speed sensor. For the...
    5 replies | 135 view(s)
  • Chris from Washington's Avatar
    1 Week Ago
    Hi, welcome to the forum, your deck is a little confusing, but I think I have it mostly figured out. See above.
    5 replies | 135 view(s)
  • Briankanexyz's Avatar
    1 Week Ago
    Briankanexyz replied to a thread Wiring help in Deck Help
    I took a stab at it, let me know what you think. Kia ________________________________Head Unit Red - 6 volts camera power ____________ Red Blue - power antenna__________________Blue/White??...
    5 replies | 135 view(s)
  • Briankanexyz's Avatar
    1 Week Ago
    Briankanexyz started a thread Wiring help in Deck Help
    Hello, I'm a bit overwhelmed with all the wires. I have no issue connecting them and installing the unit in my car, but getting the correct wires paired is a bit daunting. Was hoping someone could...
    5 replies | 135 view(s)
  • Chris from Washington's Avatar
    3 Weeks Ago
    Hi, welcome to the forum. If you're talking about a typical deep cycle battery used in RV's.. They are meant to be trickled charged, drained and repeat. Personally, I would do the 'Big 3'...
    1 replies | 114 view(s)
  • mattman2040's Avatar
    3 Weeks Ago
    Purchased 1 kicker L7 running at 900w rms with a compatible amplifier. Would anybody lend some insight as to If I should purchase a deep cycle battery for this setup, and if so what brand would...
    1 replies | 114 view(s)
  • Joeslacker's Avatar
    3 Weeks Ago
    Just typed a whole paragraph of stuff then when I went to copy just in case something went wrong with it going through I accidently pasted what I preivously coppied and deleted everything but to summ...
    6 replies | 171 view(s)
  • OnYrMrk's Avatar
    3 Weeks Ago
    OnYrMrk replied to a thread Member roll call in Off Topic
    Hey Dice!! Good to hear from you! You might look into Italia Hi-Fi for some awesome component speakers. You can check them out here: Car Audio Distribution | CV Distribution Audio | Texas I am...
    29 replies | 3918 view(s)
More Activity
[Output: 48.32 Kb. compressed to 44.86 Kb. by saving 3.46 Kb. (7.16%)]