User Tag List

Thank You Thank You:  0
Likes Likes:  0
Dislikes Dislikes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Help again

  1. #1
    Junior Member
    Join Date
    Jun 2019
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Help again

    Would my amp be too small, my wires, or some other problem if everytime I turn my radio to a certain volume it sends my amp into protection mode until I turn it down again. I have a 2400 watt kicker amp with 2 1200 watt rms massive 12" subs the power and ground wires are 4ga and the speaker wires are 10ga. Also if the box is too small would it do It too?

    Sent from my SM-G892A using Tapatalk


  2. #2
    Shitters full! Chris from Washington's Avatar
    Join Date
    Oct 2004
    Posts
    5,902
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    OzzModz Classifieds
    1

    Default Re: Help again

    Quote Originally Posted by guidrozb1996 View Post
    Would my amp be too small, my wires, or some other problem if everytime I turn my radio to a certain volume it sends my amp into protection mode until I turn it down again. I have a 2400 watt kicker amp with 2 1200 watt rms massive 12" subs the power and ground wires are 4ga and the speaker wires are 10ga. Also if the box is too small would it do It too?

    Sent from my SM-G892A using Tapatalk
    Hi Welcome to the forum.
    Let's see if we can figure out the issue. Could you let us know the model number of the amp, and also the subs you have?
    Also how do you have them wired?

    Where is your gain setting on the amp set too?

    Last question, where is your amp grounded?


  3. #3
    Junior Member
    Join Date
    Jun 2019
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Help again

    Quote Originally Posted by Chris from Washington View Post
    Hi Welcome to the forum.
    Let's see if we can figure out the issue. Could you let us know the model number of the amp, and also the subs you have?
    Also how do you have them wired?

    Where is your gain setting on the amp set too?

    Last question, where is your amp grounded?
    It's not a sub/amp issue it's been there before I got the subs so its deffinately a radio issue

    Sent from my SM-G892A using Tapatalk


  4. #4
    Junior Member
    Join Date
    Jun 2019
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Help again

    Quote Originally Posted by guidrozb1996 View Post
    It's not a sub/amp issue it's been there before I got the subs so its deffinately a radio issue

    Sent from my SM-G892A using Tapatalk
    I'm sorry wrong post. Give me a second to find it

    Sent from my SM-G892A using Tapatalk


  5. #5
    Junior Member
    Join Date
    Jun 2019
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Help again

    Quote Originally Posted by guidrozb1996 View Post
    I'm sorry wrong post. Give me a second to find it

    Sent from my SM-G892A using Tapatalk
    Amp is a kicker c1200.1 and I couldnt find the sub model from google I'm at work right now and the subs are in my suv at the office. Wires are ran from the battery to the amp ground is to a bolt under my seat with metal on both sides and the remote is ran from my deck to the amp along with my rca cables power wire is ran through my firewall on the drivers side and the rca abd remote wires ran through my passenger side

    Sent from my SM-G892A using Tapatalk


  6. #6
    Junior Member
    Join Date
    Jun 2019
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Help again

    Quote Originally Posted by guidrozb1996 View Post
    It's not a sub/amp issue it's been there before I got the subs so its deffinately a radio issue

    Sent from my SM-G892A using Tapatalk
    Gain is set to half wayish

    Sent from my SM-G892A using Tapatalk


  7. #7
    Shitters full! Chris from Washington's Avatar
    Join Date
    Oct 2004
    Posts
    5,902
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    OzzModz Classifieds
    1

    Default Re: Help again

    Quote Originally Posted by guidrozb1996 View Post
    Amp is a kicker c1200.1 and I couldnt find the sub model from google I'm at work right now and the subs are in my suv at the office. Wires are ran from the battery to the amp ground is to a bolt under my seat with metal on both sides and the remote is ran from my deck to the amp along with my rca cables power wire is ran through my firewall on the drivers side and the rca abd remote wires ran through my passenger side

    Sent from my SM-G892A using Tapatalk
    OK, so I would try and find out the model of the subs. Need to know what the impedance of the subs are.
    I want to make sure you don't have them wired in a way, that would cause issues with the amp. The amp is able to go down to a 2 ohm load.

    Once we find out everything is OK with the wiring of the subs, I would next try turning down the gain.

    But first let's figure out the subs and how they are wired.


  8. #8
    Moderator OnYrMrk's Avatar
    Join Date
    Oct 2005
    Location
    Moore, Oklahoma
    Posts
    3,210
    Mentioned
    3 Post(s)
    Tagged
    3 Thread(s)

    Default Re: Help again

    That Kicker amp is only stable to 20hms mono. You are running two 12" Massive subs. As Chris stated, you might want to check the impedance rating of your subs. If you have them wired to give that amp a 1ohm load or lower, this is your problem. Any other configuration on the subs would be fine.

    IASCA Certified SQ Judge
    USACi Certified SQ Judge
    MECA Certified SQ Judge
    2010 USACi Spring Break Jam Modified SQ Champion
    Moderator for https://www.facebook.com/groups/524841581331183/
    CVD Audio Sales and Acquisitions Team
    www.cvdaudio.com

  9. #9
    Junior Member
    Join Date
    Jun 2019
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Help again

    That is where my knowledge stops I just know how to run the wires and set the amp idk about ohms and load and stuff

    Sent from my SM-G892A using Tapatalk


  10. #10
    Junior Member
    Join Date
    Jun 2019
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Help again

    Model for the subs are cw 12 stg2 and amp is kicker c 1200.1

    Sent from my SM-G892A using Tapatalk


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
[Output: 90.35 Kb. compressed to 79.81 Kb. by saving 10.54 Kb. (11.67%)]