Tab Content
guidrozb1996's Activity
About Me
My Vehicles
Mentions
Thread Tags
Quotes
Post Thanks / Like
OzzModz Classifieds
  • guidrozb1996's Avatar
    1 Week Ago
    guidrozb1996 replied to a thread Help again in Amplifier Help
    Model for the subs are cw 12 stg2 and amp is kicker c 1200.1 Sent from my SM-G892A using Tapatalk
    9 replies | 224 view(s)
  • guidrozb1996's Avatar
    3 Weeks Ago
    guidrozb1996 replied to a thread Help in Deck Help
    I connected the ground to the ground wire on the deck ima try to upgrade to a better deck when I get home Sent from my SM-G892A using Tapatalk
    4 replies | 128 view(s)
  • guidrozb1996's Avatar
    3 Weeks Ago
    guidrozb1996 replied to a thread Help again in Amplifier Help
    That is where my knowledge stops I just know how to run the wires and set the amp idk about ohms and load and stuff Sent from my SM-G892A using Tapatalk
    9 replies | 224 view(s)
  • guidrozb1996's Avatar
    3 Weeks Ago
    guidrozb1996 replied to a thread Help in Deck Help
    Speakers are going through deck no amp other than the subs Sent from my SM-G892A using Tapatalk
    4 replies | 128 view(s)
  • guidrozb1996's Avatar
    3 Weeks Ago
    guidrozb1996 replied to a thread Help again in Amplifier Help
    Gain is set to half wayish Sent from my SM-G892A using Tapatalk
    9 replies | 224 view(s)
  • guidrozb1996's Avatar
    3 Weeks Ago
    guidrozb1996 replied to a thread Help again in Amplifier Help
    Amp is a kicker c1200.1 and I couldnt find the sub model from google I'm at work right now and the subs are in my suv at the office. Wires are ran from the battery to the amp ground is to a bolt...
    9 replies | 224 view(s)
  • guidrozb1996's Avatar
    3 Weeks Ago
    guidrozb1996 replied to a thread Help again in Amplifier Help
    I'm sorry wrong post. Give me a second to find it Sent from my SM-G892A using Tapatalk
    9 replies | 224 view(s)
  • guidrozb1996's Avatar
    3 Weeks Ago
    guidrozb1996 replied to a thread Help again in Amplifier Help
    It's not a sub/amp issue it's been there before I got the subs so its deffinately a radio issue Sent from my SM-G892A using Tapatalk
    9 replies | 224 view(s)
  • guidrozb1996's Avatar
    3 Weeks Ago
    guidrozb1996 started a thread Help again in Amplifier Help
    Would my amp be too small, my wires, or some other problem if everytime I turn my radio to a certain volume it sends my amp into protection mode until I turn it down again. I have a 2400 watt kicker...
    9 replies | 224 view(s)
  • guidrozb1996's Avatar
    3 Weeks Ago
    guidrozb1996 started a thread Help in Deck Help
    Alright I know this is the basics but I've been trying to figure out why I have feedback coming from my head unit. It's the annoying alternator feedback that gets worse as I accelerate more. I added...
    4 replies | 128 view(s)
No More Results
About guidrozb1996

Basic Information

Date of Birth
August 14, 1996 (22)
About guidrozb1996
System:
Head Unit:
Interior Speakers:
Amplifiers:
Subwoofers:
Box:
Wiring:
Electrical:

Statistics


Total Posts
Total Posts
10
Posts Per Day
0.37
Last Post
Help again 1 Week Ago
General Information
Last Activity
5 Days Ago
Join Date
06-20-19
Referrals
0
  • No Listings in the database at this time.
No results to display...
No results to display...

06-20-19


No results to show...

Active Classifieds

This Member does not has any Active Classified

[Output: 47.06 Kb. compressed to 43.44 Kb. by saving 3.62 Kb. (7.69%)]