Car Audio Central - Anything and Everything car audio - Powered by vBulletin

User Tag List

Thank You Thank You:  0
Likes Likes:  1
Dislikes Dislikes:  0

1990 Views Results 1 to 4 of 4

  1. Previous Thread

    Best amp for 2 AB XFL 12s

    Started by MuNchiezzz at 12-13-19, 04:27 PM

    Next Thread

    help with fuse issue

    Started by FG1200P403 at 04-06-20, 12:05 PM

    What Members Wrote...

  2. Chris from Washington

    Shitters full!
    12-17-19 #2

    Default Re: Amplifier makes no difference in quality

    Hi,
    So it sounds like either something isn't hooked up correctly, or maybe a possible deck issue.
    Double check all your connections, and settings on the deck.

    just the issues of the 1 speaker not working at all, and the rear channels not working something isn't right. Are there any settings on the deck, where you need to turn 'on' the rear RCA channels?

    What brand speakers are you using?

  3. Joeslacker

    Junior Member
    01-02-20 #3

    Default Re: Amplifier makes no difference in quality

    Quote Originally Posted by Chris from Washington View Post
    Hi,
    So it sounds like either something isn't hooked up correctly, or maybe a possible deck issue.
    Double check all your connections, and settings on the deck.

    just the issues of the 1 speaker not working at all, and the rear channels not working something isn't right. Are there any settings on the deck, where you need to turn 'on' the rear RCA channels?

    What brand speakers are you using?
    I'm using polk audio mm1 mm692's. The deck was indeed bad as our new 80 prs pioneer head unit did fix the fader issue and the rear channels not working. BUT the quality is still relitively bad as compared to the deck power to my old 60 watt power handling speakers.

    We are going to hook up just the power amplifier and the speakers to a new power supply thats not 30 amp but 45 or 50 this way we can rule out the amp being bad vs the draw from the power supply being too much or I guess in other words the powery supply not being enough to fully drive the amp as someone else has suggested.

    Any thoughts?

  4. Eddie9320

    Junior Member
    01-30-20 #4

    Default Re: Amplifier makes no difference in quality

    and make sure gain is set properly and try other line level.. bad RCA grounding perhaps
    Last edited by Eddie9320; 01-30-20 at 04:55 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 
[Output: 54.61 Kb. compressed to 50.38 Kb. by saving 4.23 Kb. (7.75%)]