User Tag List

Thank You Thank You:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Apr 2020
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default help with fuse issue

    just wondering what fuse to use on my amp, Thanks Alex


    PYLE Millenia 1200 Watt PLM 403


    Last edited by FG1200P403; 04-10-20 at 09:14 AM.

  2. #2
    Shitters full! Chris from Washington's Avatar
    Join Date
    Oct 2004
    Posts
    5,965
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    OzzModz Classifieds
    1

    Default Re: help with fuse issue

    Hi,
    Welcome to the forum, are you asking about what fuse near the battery you should use?
    Is this the only amp in your system?

    If it's the only amp in your system, try and find a mainline fuse around the same size as the built in fuse in the amp.

    Remember the mainline fuse is to protect the wire in case of short, not to protect the amp (that's what the built in fuse is for).


  3. #3
    Junior Member
    Join Date
    Apr 2020
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: help with fuse issue

    Quote Originally Posted by Chris from Washington View Post
    Hi,
    Welcome to the forum, are you asking about what fuse near the battery you should use?
    Is this the only amp in your system?

    If it's the only amp in your system, try and find a mainline fuse around the same size as the built in fuse in the amp.

    Remember the mainline fuse is to protect the wire in case of short, not to protect the amp (that's what the built in fuse is for).
    Thanks for reply ,the fuse I'm looking for is on the amp itself {the built in fuse on the amp} there are 2 of them , its on the physical amp ,Thanks Alex

    Last edited by FG1200P403; 04-10-20 at 09:01 AM.

  4. #4
    Junior Member
    Join Date
    Apr 2020
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: help with fuse issue

    this amp was found in garbage ,I opened it and found the ground wire fried so I replaced it ,I used a 5 amp and a 15 amp fuse that was the built in fuse for the amp.so if the ground wire was fried other things may have been damaged .I looked over amp but nothing else looks burnt or damaged ,is it worth to pursue on this amp .Thanks Alex

    Last edited by FG1200P403; 04-10-20 at 09:13 AM.

  5. #5
    Shitters full! Chris from Washington's Avatar
    Join Date
    Oct 2004
    Posts
    5,965
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    OzzModz Classifieds
    1

    Default Re: help with fuse issue

    Quote Originally Posted by FG1200P403 View Post
    this amp was found in garbage ,I opened it and found the ground wire fried so I replaced it ,I used a 5 amp and a 15 amp fuse that was the built in fuse for the amp.so if the ground wire was fried other things may have been damaged .I looked over amp but nothing else looks burnt or damaged ,is it worth to pursue on this amp .Thanks Alex
    sorry, I haven't been able to find any specs on this amp.
    But it being a PYLE I wouldn't spend much time on it. They are really low budget equipment.

    If the ground wire inside was fried, that means something drew a ton of current.
    So most likely what happened was there may have been an issue with it, and someone tried a larger fuse and then it drew so much current it fried the board.


  6. #6
    Junior Member
    Join Date
    Apr 2020
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: help with fuse issue

    Thanks Chris , kind of my thoughts about it also , inside doesn't look to be good quality to my limited observation. have good day ,take care, Alex
    really a pyle of garbage LOL

    I also have another another non working amp ,its a rockford fosgate punch 200.2 trans ana ,do you any experience with these

    Last edited by FG1200P403; 04-17-20 at 02:39 PM.

  7. #7
    Shitters full! Chris from Washington's Avatar
    Join Date
    Oct 2004
    Posts
    5,965
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    OzzModz Classifieds
    1

    Default Re: help with fuse issue

    Quote Originally Posted by FG1200P403 View Post
    Thanks Chris , kind of my thoughts about it also , inside doesn't look to be good quality to my limited observation. have good day ,take care, Alex
    really a pyle of garbage LOL

    I also have another another non working amp ,its a rockford fosgate punch 200.2 trans ana ,do you any experience with these
    The Fosgate would be worth fixing, is it one of the oval black ones? Those are classics.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
[Output: 72.57 Kb. compressed to 63.82 Kb. by saving 8.75 Kb. (12.06%)]