User Tag List

Thank You Thank You:  0
Likes Likes:  0

Page 1 of 2 12

13694 Views Results 1 to 10 of 13

  1. Previous Thread

    Outside speakers

    Started by Battousai at 04-25-08, 09:25 AM

    Next Thread

    Focal sub installed

    Started by tomcat at 04-28-08, 01:28 PM

    What Members Wrote...

  2. Purple RS

    Senior Member
    04-28-08 #2

    Default

    Quite a few years ago I had a... I want to say DCA 600 I believe it was. It was the 6 channel variety which ran my whole system. The car it was in was stolen in '97. I can't remember offhand what the power rating on the thing was, but I was impressed with it, even running all channels at 2 ohm without knowing if it was stable there or not. It never shut down or went into protection on me.

    I like Denon stuff, my home AV receiver is Denon....

  3. Audiophile

    Senior Member
    04-28-08 #3

    Default

    Yeahp, this'd be this 6 channel one. The 600 might be as well, I can't find squat for info on any of the Denon mobile amplifiers. My home audio receiver is a Denon as well, and I'm SUPER impressed with it, so if this amp is the same quality, I'll be the proud owner very soon

  4. Ryan from Ohio

    Master of My Domain
    04-28-08 #4
    -Ryan
    [SIZE=3]www.caraudiocentral.net - Your #1 Car Audio Resource on the Net![/SIZE]

  5. Audiophile

    Senior Member
    04-28-08 #5

    Default

    Erm, call me stupid, but what am I supposed to be looking at on that link?

  6. Ryan from Ohio

    Master of My Domain
    04-28-08 #6

    Default

    Thats the amp your looking at, and its insides. Look how crappy its laid out and looks...
    -Ryan
    [SIZE=3]www.caraudiocentral.net - Your #1 Car Audio Resource on the Net![/SIZE]

  7. kevinberry1

    Senior Member
    04-29-08 #7

    Default

    Why is that amp's board divided into separate sections? I admit I don't know much about amps' internal designs but that looks strange.

  8. falkenbd

    Master of My Domain
    04-29-08 #8

    Default

    I'd like to point out, 2x30A fuses. That should give some insight.

  9. Ryan from Ohio

    Master of My Domain
    04-29-08 #9

    Default

    Its an older amp, its design isnt very nice looking. Im havign a hard time determining which section is the power section or if there is a power section... lmao

    I would seriously pass on this. Unless your getting it for under $100.

    Also if they dates to about the same age as the other pieces lsited on ampguts (m sure it does) this is from like 1989-1991 area... Its way old...
    -Ryan
    [SIZE=3]www.caraudiocentral.net - Your #1 Car Audio Resource on the Net![/SIZE]

  10. Purple RS

    Senior Member
    04-29-08 #10

    Default

    Quote Originally Posted by Ryan from Ohio
    this is from like 1989-1991 area... Its way old...
    That's about the time frame mine came from, may even have been the same amp. I couldn't complain at the time and it did good by me. Wouldn't handle what I'm doing now...

Page 1 of 2 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 
[Output: 79.27 Kb. compressed to 72.15 Kb. by saving 7.13 Kb. (8.99%)]