Threads in This Forum
Page 1 of 13 123411 ...

Started by JeremyC, 08-30-20

Finally!!!! For those of you that do not know, I’ve been without a full system for almost 8...

Thanks for taking a look, all feedback is greatly appreciated. Any questions you may have feel...

Hi all. I'm Justin. I've been doing car audio as a hobbyist now for the better part of 20 years....

This has been about a 4 year project. This is the first car I've ever bought, and I've had it...

Started by scotts1000rr, 03-05-20

Its been a long time since I posted anything. This was about 5 years ago. Still have it. ...

Started by LBaudio, 11-28-18

a couple of pics of finished front end, redone amprack and SE enclosure

Started by slovell1, 02-25-18

Just finished this a couple of weeks ago. Not much room in the trunk in one of these.

Sent from my iPhone using Tapatalk

Started by jayboe3, 03-06-14

Hey! New member here. Been into car audio for about 3 years and been installing for about 2. I...

Started by Minorjames92, 05-13-17

I recently replaced my ap3000.1 with an re audio zxt v2 amp.I bought it new from a local car audio...

Started by jameslewis537, 12-08-16

Hi there guys I'm new to the forum but been installing subs for years as a hobby but I'm stuck with...

I just picked this up for 300 bucks. It has a 2.9, 5 speed, 4wd. It has the stx package.... the...

Started by Tim, 04-18-10

Hey as most of you know I got me a truck last summer. well I been doin a little at a time when/as...

Hi Everyone This is my 1984 Ford Laser Turbo that I have owned for 24 years. I have had this...

Started by snoogins, 12-21-07

I just got my CSS SDX15 yesterday, and I decided on a box. Originally I was going to seal it a...

Started by MobileAudio219, 03-14-13

1987 Mustang GT, 5.0 Liter V8, 5 speed. Mods Include: Mass Air Conversion E-fan E-Cam CAI...

Hey guys, after a long long time I'm back with a few install threads....this will be one of...

So I've had a lot of projects get started and pretty much none have been finished yet. As I get...

Started by colemanyoungerinalaska, 09-18-10

heres my car and my current setup had to take out the x1.10s dont have an amp to push them used...

Started by Maniek, 07-19-12

Welcome colleagues from the great water Auto Purchased in January of this year. Audio done on a...

Page 1 of 13 123411 ...

Forum Information and Options

Moderators of this Forum
 
[Output: 148.15 Kb. compressed to 136.38 Kb. by saving 11.77 Kb. (7.94%)]